PowerShell 4.0 Now Available for Download

That’s right, Windows Management Framework 4.0 is now available to download for down-level OS’s. Some important things to know regarding this:

New Features and Updated Versions

  • Windows PowerShell
  • Windows PowerShell Integrated Scripting Environment (ISE)
  • Windows PowerShell Web Services (Management OData IIS Extension)
  • Windows Remote Management (WinRM)
  • Windows Management Infrastructure (WMI)
  • Windows PowerShell Desired State Configuration (DSC)

Supported Down-level Operating Systems (Already available with Windows 8/8.1 and Windows Server 2012 R2)

  • Windows 7 SP1
  • Windows 7 Embedded
  • Windows 2008 R2 SP1
  • Windows Server 2012

Unsupported Platforms (Installing on these platforms could cause serious issues)

  • System Center 2012 Configuration Manager (not including SP1)
  • System Center Virtual Machine Manager 2008 R2 (including SP1)
  • Microsoft Exchange Server 2013, Microsoft Exchange Server 2010 and Microsoft Exchange Server 2007
  • Microsoft SharePoint 2013 and Microsoft SharePoint 2010
  • Windows Small Business Server 2011Standard

.Net 4.5 Needs to be installed!!!!

There are issues that if you do not have .Net 4.5 installed on your system and attempt to load WMF 4.0, it will silently fail and will still continue to load 3.0 instead (you can verify by running $PSVersionTable to see.

Download Here

http://go.microsoft.com/fwlink/?LinkId=293881

Enjoy!

About Boe Prox

Microsoft Cloud and Datacenter MVP working as a SQL DBA.
This entry was posted in News, powershell and tagged , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s